How can we help?

If you are looking for support for our Poka theme, this is the place!

Home Forums Poka v2 support Review URL Structure

This topic contains 2 replies, has 2 voices, and was last updated by  Kevin 3 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2089

    Kevin
    Participant

    Hello. I know you’ve covered this in detail here, but I just can’t figure it out so I was hoping you could give me a little insight as to exactly what I need to do. By the way, I am trying to use this theme on an existing website that already has lots of content.

    In short, my permalinks are setup as /blog/%postname%/. So my issue is when I go to create a review, the url looks like http://www.mywebsite.com/blog/reviews/site-name/. I basically need to figure out how to get /blog/ out of that link. I made the changes to the functions.php file so I could have /reviews/ name set to my liking, but I still can’t figure out how to get /blog/ out of the url.

    I also downloaded all 3 plugins you recommended in your tutorial and I still can’t get it right. I will admit I dummy up a little with the terms taxonomy, slugs ect..

    So in closing, if I go and create a review now, my link looks like http://www.mywebsite.com/blog/reviews/site-name/ and I want it to look like http://www.mywebsite.com/reviews/site-name/. Can you please tell me how to go about this? I have all my news under /blog/, so taking that out of all permalinks is not an option for me.

    Thanks, I’m really looking forward to using your theme if I can get this issue squared away.

    #2090

    admin
    Keymaster

    Hi Kevin!

    As I can understand from your post you have changed in Permalink Settings the Custom Structure to “/blog/%postname%/” and all your links now have the “blog” in URL.

    This has nothing to do with the theme and no matter what theme/plugin you are going to use the structure in the URLs is going to be the same because of that setting you made.

    Because the logic to add the word “blog” to the general URL structure is wrong this is what I suggest you to do:
    1) Remove “blog” from custom structure and leave only “/%postname%/”
    2) Then create a category in your posts called “Blog” and assign the category to all of your posts and now only the posts will have the URL structure “/blog/post-name”

    #2096

    Kevin
    Participant

    10-4. Thanks for the reply.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.