How can we help?

If you are looking for support for our PokaTheme, this is the place!

Home Forums PokaTheme support Page not found – WPML

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #6114
    Emre Goktas
    Participant

    Hi guys,

    My hosting and WPML support has been investigating the issue for a long time. I’ve decided to ask it here – when I add a translation the translations come as page not found 404 until I change/save the permalinks. When I change/save the permalinks then the source language is giving 404 error.

    Do you think you can help me with that as I cannot translate the theme so far with WPML?

    #6121
    admin
    Keymaster

    Hi Emre,

    This is issue is regarding the Reviews CPT of the theme or also in pages/posts?
    I believe it is normal when you add a new language to have to refresh your permalinks. But after the refresh the default language is not working at all? So the whole site is giving in every situation 404 error?

    #6123
    Emre Goktas
    Participant

    Hi admin,

    The issue is regarding Reviews. For example en/review/mr-green is working while de/erfahrungen/mr-green is not. or the other way around when the permalinks updated. so far, the posts/pages are functional and working properly. Only the reviews causing errors. I’d love to get your support if there is anything you can do about that.

    #6124
    Samuel Gramstad
    Participant

    I’ve got this exact same issue, somehow i’m unable to access the reviews.

    #6131
    Emre Goktas
    Participant

    Hi again guys, it is turned out to be a theme issue. I’ve tried on another theme, everything is working smoothly, as I mentioned all of the translation of page/posts elements also working correctly on Poka Theme. I’ve only issues on review elements. It is damaging the website as hell. Can I get instant support on that, please?

    #6132
    admin
    Keymaster

    Hi everyone!

    I had a look on this issue and the problem is how you did the translation of the slug of the reviews CPT.
    I believe that you used the field “Review post type slug” from Theme Settings -> Translations in order to add different slugs for each language?

    The correct way with WPML is to leave the “Review post type slug” field empty for all the languages in Theme Settings (It is very important to be empty in every language in order to use the default “review” slug).

    After that you go to WPML -> Settings -> Post Type Translation .
    You find the “Reviews” and make it “Translatable – only show translated items”.
    Under this option you’ll find another option called “Set different slugs in different languages for Reviews.”.
    With this option you’ll be able to add different slugs for the CPT “Reviews”.

    I tested it and it works just fine!

    #6134
    Emre Goktas
    Participant

    Awesome! That is the solution, thanks a lot!

    #6542
    Emre Goktas
    Participant

    Hi there, I have the same issue for post slugs. When translated, one of the languages is redirecting to 404. any help, please?

    #6666
    Emre Goktas
    Participant

    Can I get some help with this, please?

    #6679
    admin
    Keymaster

    Hi Emre,

    Because we are not WPML experts and I’m not sure I understood your problem I believe the most suitable place is the support forum of WPML for this type of questions.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.