How can we help?

If you are looking for support for our PokaTheme, this is the place!

Home Forums PokaTheme support Can’t disable Users must be registered and logged in to comment

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #11720
    cabhal
    Participant

    Hello,

    I have this issue on 2 websites using Poka Theme. Every time I disable “Users must be registered and logged in to comment”, the system doesn’t “accept” my choice, checking again the box “Users must be registered and logged in to comment”

    • This topic was modified 6 months ago by cabhal.
    #11731
    candyman
    Participant

    I have the same issue and I hadn’t fixed it. I found only one solution, not the best, I added code from this forum for function.php so now I have 2 fields with register, another without.

    #11742
    admin
    Keymaster

    Hi cabhal,

    Exactly, this option is enabled by default by the theme because this is how we decided is best for the reviews ratings.
    If you want to disable you can check the following topic: https://pokatheme.com/topic/commenting-by-guests/

    We plan to improve this part in the future versions of PokaTheme.

    #11749
    cabhal
    Participant

    The URL is a 404

    #11771
    cabhal
    Participant

    Hello guys?

    #11778
    admin
    Keymaster

    Hi!

    The URL is working just fine to me.
    Can you please try again?

    #11783
    cabhal
    Participant

    Still 404 this URL: https://pokatheme.com/topic/commenting-by-guests/ – I’ve tried also with anon browser

    #11807
    cabhal
    Participant

    Can you check??

    #11890
    admin
    Keymaster

    I’m sorry but I can see the link above just fine…

    I’m sending the solution also here:

    You can add the following snippet to your child theme functions.php to enable guest users comments

    function poka_child_init(){
    update_option( ‘comment_registration’, 0 );
    }
    add_action( ‘init’, ‘poka_child_init’ );
    #12329
    Denno
    Participant

    Hey,

    It’s not working for me (neither the link which leads to a 404, nor the code which I entered into my child theme functions.php.

    //enable guest comments
    function poka_child_init(){
    update_option( ‘comment_registration’, 0 );
    }
    add_action( ‘init’, ‘poka_child_init’ );
    //end enable guest comments

    The comment section is very important for me to be used by guests. I also tried another solution which was offered by a person in this support forum, but it also didn’t work 🙁

    Do you know why it doesn’t work for me? Or a work around?

    Thanks,
    Denno

    • This reply was modified 3 months, 3 weeks ago by Denno.
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.