How can we help?

If you are looking for support for our PokaTheme, this is the place!

Home Forums Child Themes support WPML – separate pages ignore all edits so far

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #5773
    Man Sh
    Participant

    Hey, so after finally being happy with the edits I made to the theme and getting it to look the way I want it to, I tried installing WPML.

    However if I select language directories – for example website.com/ru, poka reverts all changes and the styling completely breaks.

    Even my top right Logo becomes ForexOptions once again on any translated pages containing the language category – Back to the demo version I started off with.

    Any possible solutions?

    Thanks in advance.

    #5781
    admin
    Keymaster

    Hi Man,

    Can you please send me an example to check your issue?
    You can mark your post as private.

    #5782
    Man Sh
    Participant
    This reply has been marked as private.
    #5833
    admin
    Keymaster

    Hi Man,

    I checked your site and most probably your issue is because you have set to have the Theme Options of the theme to be translatable by WPML.
    Because the Theme Options are set to be translatable for each language you can have separate Theme Options and in the Russian translation the Theme Options are blank.
    You can add your custom Theme Options for each language again or you can make the Theme Options to be excluded from WPML so it can be the same for all the languages. (I’m not sure if this the correct option because probably some text field in theme options need to be language specific)

    #5907
    Man Sh
    Participant

    Hi, Admin

    I don’t have access to “Theme Options” anywhere on the website using Poka or Forex themes. It simply doesn’t exist in the Appearance menu.
    I do have “Theme Settings” but there’s nothing about WPML in it.
    This setting is nowhere to be found in WPML either
    Could you point me to the setting?

    • This reply was modified 2 months, 3 weeks ago by Man Sh.
    #6002
    admin
    Keymaster

    Because you are using the Forex child theme as I can see you should have “Theme Settings” menu in your Dashboard and not “Theme Options”.
    If you don’t see the menu item at all please check if you have ACF in your plugins, deactivate it and check again.

    #6095
    admin
    Keymaster

    The topic is marked as resolved due to inactivity.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.